ak|weblog

Version 2

Ein neues Gewand über einem neuen Gerüst. Die komplette Site läuft nun auf Textpattern, das Weblog und die übrigen Bereiche sind somit aus einem Guß.

Dazu einige Neuerungen und Schmankerl, z.B. verschiedene RSS und Atom Feeds für die einzelnen Bereiche der Site: natürlich das Weblog, aber auch die Webdesign Links, die Buchtipps und andere mehr. Die alten Feed-URLs werden umgeleitet, aber wer möchte, kann natürlich auch auf die neuen umstellen.

Außerdem ist der bisherige Bereich “Australien” zum Bereich Fotos geworden, wo es nun eine Auswahl verschiedener Fotosets zu sehen gibt. Umfangreichere Alben sind zu flickr umgezogen.

Ansonsten habe ich versucht, die bewährten Designkonzepte beizubehalten und mit den Sahnehäubchen zu garnieren, die ein Content Management System bietet.

Alle wichtigen Dinge habe ich getestet. Natürlich sind aber Browserprobleme nicht ausgeschlossen. Wenn also etwas seltsam aussieht oder sich komisch verhält, würde ich mich über einen Hinweis freuen.

Ein wenig Irrationalität ist wie immer im Spiel: Textpattern ist noch nicht in der Version 1.0 erschien, so dass sich noch Änderungen am CMS ergeben können. Die Vernunft würde sagen: abwarten. Aber manche Dinge müssen irgendwann einfach fertig werden.

Ich freue mich, hiermit das Projekt mit dem internen Codenamen “ak-v2” offiziell zu präsentieren.

Geschrieben spät nachts am 02. April 2005
Abgelegt unter Webwork & Persönlich

1Jeena Paradies schrieb am 3. April 2005, 08:19 h    # 

Sehr schön geworden. Es ist durch den höheren Kontrast viel leichter zu lesen und dadurch dass nun nicht mehr das ganze Hintergrundbild beim scrollen stehen bleibt, lässt sich die Seite auch viel schneller scrollen.

2Sabine schrieb am 3. April 2005, 09:03 h    # 

Sieht scharf aus. Aber das alte habe ich auch immer bewundert.

3ak schrieb am 3. April 2005, 11:40 h    # 

Jeena, der Kontrast war mir in letzter Zeit auch ein Dorn im Auge. Ich wollte die Farben etwas “frischer” machen.

Zum Hintergrundbild, es gibt jetzt ja wieder ein statisches, aber die fixierten Bereichsüberschriften sind jetzt weg. Vielleicht haben die das Problem gemacht.

4kronn schrieb am 3. April 2005, 19:57 h    # 

Wundervolle Arbeit. Zum einen technisch (weil ich jetzt mit Textile kommentieren kann), zum anderen grafisch. Obwohl du auf den ersten Blick nicht allzuviel geändert hast, wirkt es doch angenehm frisch.

Wie hast du den Wechsel der alten Blogeinträge vollzogen? Gab es dafür ein Import-Skript?

5ak schrieb am 3. April 2005, 20:09 h    # 

Die neueste Textpattern Version (RC3) hat ein eingebautes Importskript für Movable Type, Wordpress und b2.

Hat alles wunderbar geklappt, nachdem ich das Glück hatte, mit kusor, einem der beiden neuen TXP Entwickler Importprobleme persönlich auszumerzen.

Das einzige Problem sind die URLs, die in TXP nicht so flexibel sind wie in WP. Allerdings gibt es bereits verschiedene Plugins, die auch datumsbasierte URLs wie in WP ermöglichen, z.B. zem_rewrite oder mic_permlink.

6Jeena Paradies schrieb am 3. April 2005, 20:18 h    # 

Mensch das mit den URLs ist mir ja gar nicht aufgefallen. Ich finde es aber eine wirklich interessante alternative zu den datumsbasierten URLs.

Einen kleinen Kritikpunkt habe ich aber noch. Es gibt keine permanenten Links zu den einzelnen Kommentaren.

7kronn schrieb am 3. April 2005, 20:22 h    # 

Stimmt, mir fällt auch gerade auf, das die URL des Eintrags wirklich kurz geworden ist…

Ich hoffe, du kannst dein altes Permalink-Schema zumindest auf das neue umleiten. Oder hast du vor, wieder zum bisherigen Schema zurückzukommen?

8ak schrieb am 3. April 2005, 20:28 h    # 

Jeena, doch gibt es ;-). Hatte ich vergessen und gerade ergänzt.

kronn, ich mochte die Datums-URLs eigentlich nie. Das Problem ist natürlich die Umleitung. Ich habe für die “wichtigsten” Blogeinträge, die häufig über Google verlinkt werden oder die ich wegen des Themas für wichtig halte, manuell umgeleitet: einfach mit permanenten Redirects in der .htacess Datei. Das ist natürlich keine ideale Lösung, aber für mich akzeptabel.

Es gibt einige Hoffnung, dass TXP mit der Version 1.0 das URL Schema /sektion/kategorie/titel von sich aus unterstützt. Momentan realisiere ich das noch mit den genannten Plugins, was verschiedene Problemchen schafft, z.B. in den Feeds oder mit dem "Kommentieren"-Link, der nicht über das Plugin läuft und /sektion/titel verwendet. Wenn dieses Schema in TXP eingebaut ist, werd ich sicherlich auch für das Blog dabei bleiben, zumal ich ja das datumsbasierte Archiv habe.

9kronn schrieb am 3. April 2005, 20:45 h    # 

Sobald das von dir erwähnte Schema integriert ist, wechsele ich zu TxP.

Es müsste doch aber möglich sein, über entsprechende ReWrite-Regeln beides (kategoriebasiert und datumsbasiert) umzusetzen. Letztlich wird es doch intern sowieso zu einer Datenbankabfrage.
Welche Felder abgefragt werden, ist doch egal, solange eine hinreichend genaue Antwort zurückkommt, oder?

10ak schrieb am 3. April 2005, 20:51 h    # 

Du hast Recht, irgendwie müsste man das mit mod_rewrite hinkriegen. Allerdings habe ich mir daran die Zähne ausgebissen.

Ich kenn mich damit noch recht wenig aus und erschwerend kommt hinzu, dass TXP selbst auch einige Rewrite Regeln verwendet, um die sauberen URLs zu erzeugen. Da war dann das Chaos perfekt und ich konnte beim besten Willen nicht sagen, ob der Fehler prinzipieller Natur ist (weil sich Regeln gegenseitig beinflussen) oder ob ich einfach Mist geschrieben hab.

Da ich das Design nun endlich fertig machen wollte, habe ich mich für den Moment mit dem Kompromiss abgefunden.

11kronn schrieb am 3. April 2005, 21:02 h    # 

Naja, ich denke ich bleibe bei dem, was ich schon damals gesagt habe: Ich warte erstmal auf die Version 1.0.

Ich befürchte nur, dass das noch einige Zeit dauert…

12ak schrieb am 3. April 2005, 21:23 h    # 

Tja, was die Warterei angeht, kann wohl wirklich nichts Genaues sagen. Ich hoffe aber, dass es sich nun noch in der Größenordnung von Wochen und nicht mehr Monaten bewegt.

13Jörg Petermann schrieb am 5. April 2005, 17:00 h    # 

Da komme ich am 5. April wohl etwas spät, aber dafür möchte ich das neue Design erst mal richtig loben. Es gefällt mir besser als das letzte, für mich stimmiger im Feintuning und durch die weniger Grafiken klarer, sehr freundlich.
War in der Tat auch angenehm überrascht.
Tolle Arbeit.

Das Du nun doch auf Textpattern umgestiegen bist nötigt mir Anerkennung ab. Ist immer tierisch Arbeit und man kann es nicht jeden Tag machen.

Auch die Integration Deiner Fotos ist nett gelöst und bei flickr gibt es ja die anderen.
Danke übrigens für Deine netten Hinweise zu meinen Fotos, musste wirklich darüber nachdenken, ob Du meine meinst. Selbst sieht man die Arbeit immer noch mal kritischer als ein Außenstehender.

Wünsche Dir viele Kommentare, gute Ergebnisse und freue mich über die nette visuelle Bereicherung der Bloggerlandschaft.

14Jörg Petermann schrieb am 6. April 2005, 08:04 h    # 

BTW, der IE hat natürlich wieder mal ein Flickl-Problem mit der Namensgrafik. Aber wir wollte den ja sowieso abschaffen. Nur wie?

15ak schrieb am 6. April 2005, 08:35 h    # 

Jörg, bei mir sehe ich das Problem nicht.

Welche Einstellungen hast Du für “Temporäre Internetdateien”? Wenn man in den Internetoptionen auf “Allgemein > Temporäre Internetdateien > Einstellungen” klickt, kann man den Zugriff auf Dateien aus dem Cache regeln.

Meines Wissens ist die Grundeinstellung “Automatisch”, dann sollte das Flackern (flicker) nicht auftreten. Nur wenn man “Bei jedem Zugriff” angibt.

16Jörg Petermann schrieb am 6. April 2005, 13:41 h    # 

Andreas, Du hast Recht. Da ich dabei bin, mich vom IE zu verabschieden, hatte ich diese Einstellung in der Tat schon etwas aus dem Fokus verloren. So passiert das eben, wenn man gezielt aufgefordert wird, aufmerksam auf Kleinigkeiten zu achten. (Schunzel :) )
BTW, Du hast Dir aber eine nette Schrift für den Kopf ausgesucht. Gefällt mir.

17Vitaly Friedman schrieb am 6. April 2005, 21:12 h    # 

Hallo Andreas,

ich lese deinen Blog schon seit mehrerer Monaten – gute Arbeit – weiter so! :)

Darf ich bitte fragen, welches System du früher benutzt hast? Ich habe vor, selbst so ein ähnliches System zu benutzen, weiß aber nicht, welches ich benutzen soll…

PS: ach übrigens…

vor kurzem habe ich angefangen, eine Liste nützlicher Web-design tools und Web-Tools zu sammeln, damit ich einen schnellen Zugriff auf die Web-Seiten habe, dir mir bei der Arbeit bzw. beim Studium helfen. Fragt man den alten Onkel Google, welche Seiten es mit “nützlichen Web-tools” gibt, so zeigt er eine ewig lange Liste, wobei die Links eigentlichs gar nicht so nützlich sind. Die tatsächliche nützlichen Links werden aber viel später – oder gar nicht – angezeigt.

Die aktuelle Linkliste findet man unter http://www.alvit.de/vf/en/00_webtools.html.

Somit habe ich über 160 Links gesammelt und möchte gerne auch einen Link auf deine Seite setzen. Außerdem würde ich mich freuen, wenn du auch in deiner Sammelliste einen Link auf meine Homepage bzw. auf meine Sammelliste setzen würdest.

Jedenfalls vielen Dank für deine Arbeit!

Mit freundlichen Grüßen aus Saarbrücken, Vitaly Friedman,
http://www.alvit.de/vf/

18ak schrieb am 6. April 2005, 23:05 h    # 

Vitaly, ich habe einen Link auf Deine Sammlung unter CSS > Infosammlungen und Linklisten gepostet.

19Sebastian schrieb am 7. April 2005, 08:43 h    # 

Auch wenn ich schon etwas spät dran bin:
Großes Lob, gefällt mir sehr gut dein Redesign. Die Schrift im Header ist doch Scriptina, oder? Und dass du auf Textpattern umgestiegen bist kann ich nur verstehen. Es ist einfach toll.

Zudem ist mir jetzt deine Vokabelsammlung aufgefallen. Sehr nützliche Sache!

20ak schrieb am 7. April 2005, 14:30 h    # 

Sebastian, die Schrift in header und footer ist in der Tat Scriptina.

21Bastian schrieb am 11. April 2005, 14:04 h    # 

Ich versuche auch gerade RC13 zum laufen zu gekommen, aber ich habe arge Probleme mit den Umlauten.

Ich habe einen Teil Deines Threads mit kursor gelesen und ich meine mich zu errinnern, dass Du auch Probleme mit Umlauten hattest.

Wie hast Du das gemacht?

22ak schrieb am 11. April 2005, 14:28 h    # 

Bastian, hast Du RC1 oder RC3? RC13 gibt’s nicht.

Ich benutze hier RC3 in der neuesten revision aus dem SVN Code Repository (derzeit rev277) und habe keine Probleme mit den Umlauten. In den URLs werden Ä/ä, ü/Ü, Ö/ö sowie ß in “ae”, “oe”, “ue” und “ss” umgewandelt.

23Bastian schrieb am 11. April 2005, 18:31 h    # 

RC3. Eine frische Instalation des rev277.
Als einzige Änderung habe Sprache auf Deutsch gestellt.
Umlaute werden nicht dargestellt.

Screenshot

Ich weiß zwar wie ich das per Hack ändern könnte, aber soweit ich das im Txp Form verstanden habe, sollte dass doch auch ohne Hack gehen.

24ak schrieb am 11. April 2005, 18:59 h    # 

Das scheint mir ein Problem mit dem Zeichensatz zu sein. Erscheinen die Fragezeichen auf der Seite oder auch im TXP-Adminbereich?

Welche Zeichensatz benutzt Du? Ich benutze UTF-8 ohne Probleme. Falls das auf Deinem Server nicht klar ist, kannst Du mal Folgendes in die .htacces Datei schreiben:

AddDefaultCharset UTF-8

Normalerweise sollte das reichen. Außerdem kannst Du aber noch das Content-Type meta-Element verwenden:

< meta http-equiv="Content-Type" content="text/html; charset=utf-8" / >

Achtung: nicht einfach kopieren. Ich musste nach der öffnenden und vor der schließenden Klammer eine Leerschaltung einfügen, weil Textile das anders nicht akzeptieren will.

25Bastian schrieb am 11. April 2005, 21:50 h    # 

Das Meta Tag ist ja standartmäßig im Default-Page eingebaut, aber bringt irgendwie nichts.

AddDefaultCharset UTF-8 in der .htaccess machte auch nichts.

Ich weiß nicht, wo der Fehler liegt.
Wenn ich per preg_replace Ü durch &Uuml tausche, dann klappt es natürlich.

26ak schrieb am 11. April 2005, 21:58 h    # 

Dann bin ich mit meinen Latein auch am Ende. Tut mir leid.

Was hast Du denn im Quellcode? Die Fragezeichen sind ja nur Platzhalter für Zeichen, die der Browser in diesem Zeichensatz nicht versteht.

27Bastian schrieb am 11. April 2005, 23:05 h    # 

Ich verstehe es auch nicht, aber es scheint ein Fehler im Localhost zu sein.
In der Datenbank werden die Umlaute korrekt gespeichert, daher hoffe einfach ich, dass es keine Probleme gibt, wenn ich das ganze online stelle!

Auf jeden Fall danke für die schnellen Antworten.

28ak schrieb am 11. April 2005, 23:15 h    # 

Jetzt, wo Du’s sagst: ich hatte auch einige Probleme auf der lokalen Installation, die sich dann beim Umzug in Wohlgefallen auflösten.

Es besteht also Hoffnung!

29Jörg Petermann schrieb am 16. April 2005, 18:24 h    # 

Absolut toll und sehr passend finde ich die Zitate auf Deiner Seite. Eine sehr persönliche Art der Botschaft, die ich nicht nur gern mag, sondern die auch auf meinem Wunschzettel steht. Schön ins Design integriert!

30ak schrieb am 16. April 2005, 19:07 h    # 

An den Zitaten hab ich auch selbst immer wieder Freude. Die werden zufällig mit dem Plugin dru_random_text aus einer Textdatei eingebunden.